Empty MyPlace

Please report any sort of feature requests or bugs on the tracker instead of the forum! http://tracker.anidb.info

Moderator: AniDB

Locked
User avatar
Megami
Posts: 5
Joined: Fri Jul 25, 2003 11:16 am

Empty MyPlace

Post by Megami » Wed Oct 24, 2007 2:33 pm

Hi,

I just went to check something in myPlace and found that all figures have disappeared. I've seen approx. 420 anime, I panicked a bit seeing this:
Image

I don't know if this happened to others, I hope someone can check this. :)

myList seems to be complete.

Thanks!

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

Post by Rar » Wed Oct 24, 2007 3:52 pm

http://anidb.net/perl-bin/animedb.pl?sh ... uid=105666

Looks like an error with the cron. Might have something to do with the fact every mylist entry is marked deleted, or might not.

Rar

epoximator
AniDB Staff
Posts: 379
Joined: Sun Nov 07, 2004 11:05 am

Post by epoximator » Wed Oct 24, 2007 4:05 pm

ok. it seems that this may happen if you edit your mylist while the cron is running. i'll try to fix it soon.

if you change something in your mylist now your stats should be fixed next time the cron is running, though

User avatar
Megami
Posts: 5
Joined: Fri Jul 25, 2003 11:16 am

Post by Megami » Wed Oct 24, 2007 5:07 pm

Rar wrote:http://anidb.net/perl-bin/animedb.pl?sh ... uid=105666

Looks like an error with the cron. Might have something to do with the fact every mylist entry is marked deleted, or might not.

Rar
I'm not a squirrel :lol: , I do not burn nor save on HDD. AniDB is necessary to me to keep trace of what I've seen.

I won't change anything until it's not back to normal. That way I'm sure I do not mess your work.

Thanks both of you for your answers.

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

Post by Der Idiot » Wed Oct 24, 2007 5:17 pm

well thing is if you don't change anythign it won't change. stale accounts (those in which nothing was updated since the last update) don't get updated via the cronjob.

User avatar
Megami
Posts: 5
Joined: Fri Jul 25, 2003 11:16 am

Post by Megami » Wed Oct 24, 2007 5:51 pm

Sorry, I didn't understood it that way. :oops:

I have some eps to add to mylist, I'll try that tonight.

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

Post by Rar » Wed Oct 24, 2007 6:23 pm

Der Idiot wrote:well thing is if you don't change anythign it won't change. stale accounts (those in which nothing was updated since the last update) don't get updated via the cronjob.
Considered that, but discounted by adding &do=latest and noting that there have been mylist additions well within the boundary.

I think epoxi is on the money, will just have to pamper him till he fixes up the cron.

Rar

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Thu Oct 25, 2007 8:39 am

The user was correctly marked with statsstale when I checked just now. After running the user stats cron job manually all the counters seem to be ok again too.

The issue seems to arrise only when users modify their mylist the first time within 24h exactly while the user stats cron job is running.

The problem there is that the user stats cron job does not store the list of users with statsstale set to true locally. But instead directly uses it in db queries at different points in time.
This means that if the user was not marked statsstale at the beginning, none of that users db entries will be counted. If the user is then marked with statsstale before the results are written back to the db, the user's stats are overwritten with zeros.

BYe!
EXP

User avatar
Megami
Posts: 5
Joined: Fri Jul 25, 2003 11:16 am

Post by Megami » Thu Oct 25, 2007 2:12 pm

I got back to normal.
Thanks!

(Hopefully someone at home could explain to me your tecnical terms. :oops: )

guhungry
Posts: 2
Joined: Thu Oct 25, 2007 4:48 pm

Post by guhungry » Thu Oct 25, 2007 4:56 pm

I still have the same problem.
http://anidb.net/up84121

epoximator
AniDB Staff
Posts: 379
Joined: Sun Nov 07, 2004 11:05 am

Post by epoximator » Fri Oct 26, 2007 5:49 am

could you please just read the thread? no one said it has been fixed

Locked