[cgi] CREQs lost [FIXED]

already fixed bugs

Moderator: AniDB

Locked
kidan
Posts: 319
Joined: Thu Feb 13, 2003 9:13 pm
Location: .DE

[cgi] CREQs lost [FIXED]

Post by kidan » Tue Sep 23, 2003 3:53 pm

Hi, yesterday I made a lot of creqs (I added ~30 new CRCs to existing files after comparing with official sources). But it seems that none of those was taken, as the count in MyCreqs did not change (neither open nor denied nor granted). So I guess there is a little bastard that needs some debugging (go skuld). I think I'll try chii next time... :roll:

kidan
Posts: 319
Joined: Thu Feb 13, 2003 9:13 pm
Location: .DE

Post by kidan » Tue Sep 23, 2003 4:10 pm

Strange: I just did 3 new creqs to test. Now MyCreqs says:

User: kidan (705)
Requests: 23
Open: 3
Granted: 18
Denied: 2

Your Open DB Change Requests:
Type Id Issued Action

Your past DB Change Requests:
Type Id Issued Checked State Mod Message
...

As you can see there are no open REQ listed although their count is 3. 8O

Iceman[grrrr]
Posts: 312
Joined: Sat Aug 02, 2003 3:22 am
Location: Québec, Canada

Post by Iceman[grrrr] » Tue Sep 23, 2003 6:29 pm

I tested it too... does the same... the Creq isn't in the list...

To mods: Sorry I can't delete it! :roll:

Shantock
Posts: 11
Joined: Sun Aug 31, 2003 5:05 pm
Location: Norway

Post by Shantock » Tue Sep 23, 2003 7:25 pm

Yup, encounting the same thing.. i made about 15 CREQ's today, none of them show'ed on MyCReq-list. So, i guess none of them were sent.. bitter 8O

zaufany
Posts: 127
Joined: Sat Apr 05, 2003 9:50 pm
Location: Poland

Post by zaufany » Tue Sep 23, 2003 8:01 pm

I have problems with my creqs too. They have just disappeared. Fortunately I haven't made a lot of them (yet).

[edit]They don't display on list too.[/edit]

kidan
Posts: 319
Joined: Thu Feb 13, 2003 9:13 pm
Location: .DE

Post by kidan » Wed Sep 24, 2003 12:00 am

Well, seems this random feature is not only related to myself. :x

wahaha
AniDB Staff
Posts: 1497
Joined: Sun Nov 17, 2002 3:33 pm

Post by wahaha » Wed Sep 24, 2003 7:09 am

Same here, the total and open counters change accordingly, but the creq seems to vanish.
I tried requesting the same creq twice (hoping for some "creq already existing"-error, but there was none), and again, the creq-counter changed from 211 (0 open) to 213 (2 open) :?

Is it possible that some cleanup corrects the creq-numbers later on?

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Wed Sep 24, 2003 7:26 am

well,

from the mod side i can only say that we see creqs as we always did and there are new creqs daily of which we grant most.
so my guess would be that the creqs are not lost but simply not displayed on the user creq page atm. i will look into this.
maybe some of you remember what they created creqs for and could take a look at the db if their changes have been accepted? (meaning they didn't get lost) that would help a lot.

and yes, there is a cleanup script running every now and then which makes sure the creq counters have reasonable values.

BYe!
EXP

*edit*
info: apart from 4 creqs by skywalka there are at the time of this writing, no open creqs
*/edit*

wahaha
AniDB Staff
Posts: 1497
Joined: Sun Nov 17, 2002 3:33 pm

Post by wahaha » Wed Sep 24, 2003 9:07 am

Hmm... the values are now back to 211 (0 open) for me, so at least the cleanup works properly ^^;.

To test it again, I requested a change for GaoGaiGar ep 14 (19044) [says v1, but is actually v2].
Although there's no error-message, neither the total nor the open creq counters change this time.

After re-submitting the exactly same creq though, the counters do change [212 (1 open)], but I still don't see any creq in my list and I bet the next cleanup will reset the counter to 211 (0 open) again.

EDIT (30 mins later): Yep, the values are back to 211 (0 open).

EDIT2: Odd, a change-req for the (episode-)title of Adieu Galaxy Express 999 (eid 7982) [broken non-ascii characters] seems to work properly (no error-msg, counters change, shows up in creq-list)

I did some testing with a file in test anime, but regardless of what I change, it still doesn't work (no error-msg, counters change, doesn't show up in list, can be requested multiple times)

Shantock
Posts: 11
Joined: Sun Aug 31, 2003 5:05 pm
Location: Norway

Post by Shantock » Wed Sep 24, 2003 1:06 pm

Yup, i'm still getting the same deal as wahaha... Made a Creq, it showed as "1 open" but didn't show in the "MyCReq"-list, a little later, it's back to "0 open" and the request didn't come through... Nothing happened with the file i requested change for.

kidan
Posts: 319
Joined: Thu Feb 13, 2003 9:13 pm
Location: .DE

Post by kidan » Wed Sep 24, 2003 3:14 pm

I for example added CRCs to all [e-f]-Files of Ippatu Kikimusme and set the filestate to CRC-checked. I think those Creqs were lost. (ep 9 and 10 are owned by me, so I could add the CRC there)

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Wed Sep 24, 2003 5:17 pm

i am very sorry about this.
it seems that i forgot to do some changes concerning the sha1 part for file creqs.
that means that in deed all file creqs issued since the last anidb update (22.09.03) are lost. all other creqs worked as expected though.
the problem should now be fixed.

BYe!
EXP

Skywalka
Posts: 889
Joined: Tue Sep 16, 2003 7:57 pm

Post by Skywalka » Wed Sep 24, 2003 9:16 pm

Thx EXP!

Bye :)

Oh and my creqs are still there, I saw them a minute ago ;)

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Wed Sep 24, 2003 9:21 pm

well,

your creqs are older than the bug :P

BYe!
EXP

Locked