New language/relation system - Report all bugs here!

already fixed bugs

Moderator: AniDB

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

New language/relation system - Report all bugs here!

Post by Der Idiot » Thu Apr 27, 2006 3:35 pm

minor
- streamid's should be unique globally for the file not just for 1 section (audio, video or subtitle)
- change the ownership of streams to the owner of the fileentry to make it more consistent


feature
Relations
- The relation form needs clarification. Just as described here for anime relations: http://tracker.anidb.info/view.php?id=251 The current note is still a little confusing for beginners. ;)
-drop the "NOTE:" and add the colored boxes for users for the following errors: (possible more)

Code: Select all

NOTE: ERROR: 12 - a relation is already added
NOTE: ERROR: 56 - external-sub-for relations are only allowed between a subtitle and a video file. Maybe you are trying to add the relation in the wrong direction?
Streamsystem
- drop displaying the "StreamNO" (not ID). its pointless and only confuses ppl.
- interface change suggestions: http://www.anidb.net/forum/viewtopic.php?p=26437#26437
- sanity checks ( http://www.anidb.net/forum/viewtopic.ph ... 8&start=41 )
- remove "additional translations" and "signs translated" it's just too much of a hassle to add that for all and is not autocreqable
- if hardsubs was picked you shouldn't be able to pick styling options, softsubbed karaoke
- rename karaoke to softsubbed karaoke (reset the data for it)
Last edited by Der Idiot on Mon Jun 26, 2006 11:49 am, edited 73 times in total.

User avatar
worf
Posts: 125
Joined: Mon Sep 06, 2004 8:53 pm

Post by worf » Thu Apr 27, 2006 4:22 pm

streamids are only allowed up to 32767. everything above 32767 will result in a ungrantable creq.

when adding a file as "subtitle file" it changes back to "video file" after submitting it

when you add an episode relation it says "Add file relation:" and "Other file:". same goes for the note

adding streams through the file add page seems to not work at all

drop displaying the "StreamNO" (not ID). its pointless and only confuses ppl.

adding two streams of the same type with the same streamID results in an ungrantable creq when the first of the two creqs is granted.
same happens for the streamNO.

adding new streams to a file i added: creq
editing streams i added of a file i added: no creq
editing streams someone else added to a file i added: creq
-> some consistency would be nice

creq-details dont show aid/eid/fid ... -> Stream: 325866 (streamvidtb) (File: , anime: , ep: - )

Guest

Post by Guest » Thu Apr 27, 2006 8:54 pm

In the add file page the Stream Toggle is automatically checked after the file is added. I tried editing after adding but it also didn't work. Tried adding a stream but it was sent to a mod for approval so, don't know if I messed up :(

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

Post by Der Idiot » Thu Apr 27, 2006 9:14 pm

Anonymous wrote:In the add file page the Stream Toggle is automatically checked after the file is added. I tried editing after adding but it also didn't work. Tried adding a stream but it was sent to a mod for approval so, don't know if I messed up :(

Code: Select all

- adding streams through the file add page seems to not work at all (random?!) was reported by at least 1 user, but never could reproduce that 
i guess thats that bug at work. now the question is why. i don't see it happening for me :/

EDIT
after a bit of testing it seems to be a bug related to only Internet Explorer. firefox adds the files properly. IE will just ignore all the streamsrelated data and add nothing.

saberhagem
Posts: 7
Joined: Thu Apr 27, 2006 8:54 pm

Post by saberhagem » Thu Apr 27, 2006 9:35 pm

I am that Guest. I signed up since then. By the way, I'm using Firefox 1.0.7 :-/

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

Post by Der Idiot » Thu Apr 27, 2006 9:37 pm

hmm 1.0.7 maybe that version is affected as well.

I'm using 1.5.0.2 and it works properly

edit...
rar tested with 1.07 and it worked properly :/

definitely random

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

Post by Der Idiot » Thu Apr 27, 2006 9:49 pm

ok screw that. it's not browserrelated at all.

the difference makes the userlevel.
modlevel -> works
userlevel -> fucked up

i had a 100% quote for each

User avatar
fahrenheit
AniDB Staff
Posts: 438
Joined: Thu Apr 08, 2004 1:43 am
Location: Portugal

Post by fahrenheit » Fri Apr 28, 2006 12:13 am

some mylist exports are now broken,

at least all of my templates and don gato's one are totaly broken on the anime pages.

other templates have all the file information broken.

a simple diff of a before and after:
before wrote:< f28252.resName = "640x360";
< f28252.audioBr = 169;
< f28252.audioCodecID = 6;
< f28252.audioCodecName = "MP3 VBR";
< f28252.videoBr = 1056;
< f28252.videoCodecID = 17;
< f28252.videoCodecName = "XviD";
< f28252.langID = 2;
< f28252.langName = "japanese";
< f28252.subID = 3;
< f28252.subName = "english";
after wrote:> f28252.resName = "x";
> f28252.audioBr = ;
> f28252.audioCodecID = ;
> f28252.audioCodecName = "";
> f28252.videoBr = ;
> f28252.videoCodecID = ;
> f28252.videoCodecName = "";
> f28252.langID = ;
> f28252.langName = "";
> f28252.subID = ;
> f28252.subName = "";
before noticing this i've sugested exp to produce a new sdk, but now we *need* a new sdk, i would though rate this as medium bug, solving other stuff takes precedence.

never the less a simple warning on the mylist export page warning users that due to this new feature some export templates may be broken would be a nice touch.

VeeSPIKE
Posts: 10
Joined: Fri Jul 04, 2003 3:48 pm

AOM broken?

Post by VeeSPIKE » Fri Apr 28, 2006 3:19 am

It maybe unrelated, but AOM 5.6.241 appears to broken now as well. I have been unable to connect with it all day. Did the api change, or the port perhaps?

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Fri Apr 28, 2006 6:15 am

API is probably down and aom.5 will prolly be broken for a few days.

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Fri Apr 28, 2006 9:42 am

* file adding/stream adding fixed?
* file type setting fixed?
* file/admin reports fixed?
* chii fix soon, udp api fix soon
* some minor modification

Shinnew
Posts: 73
Joined: Sun Oct 31, 2004 7:33 pm
Location: ...

Post by Shinnew » Fri Apr 28, 2006 10:20 am

Don't know if this is related, but I'm not receiving notifications anymore.

EDIT: For some reason I just got one, no idea why I got this one and not the others...
Last edited by Shinnew on Fri Apr 28, 2006 11:37 am, edited 1 time in total.

AnimeOtaku
Posts: 158
Joined: Sun Jan 09, 2005 10:54 am
Location: Germany

Post by AnimeOtaku » Fri Apr 28, 2006 10:54 am

worf wrote:streamids are only allowed up to 32767. everything above 32767 will result in a ungrantable creq.
I think the datatype you use is too small to handle the values, because 32768 is 2^15, you should use an 32bit int or 64bit long value for it(maybe unsigned if something like this exists)

User avatar
nwa
AniDB Staff
Posts: 585
Joined: Sat Jun 07, 2003 10:51 am

Post by nwa » Fri Apr 28, 2006 11:04 am

When you edit the streams individually, giving them a stream id and then you edit the whole file, the id's are reset back to having no value except for the stream that is not displayd in the file edit screen.

User avatar
ricce
Posts: 199
Joined: Wed Apr 06, 2005 8:42 pm
Location: Sweden / Västrås
Contact:

Post by ricce » Fri Apr 28, 2006 2:20 pm

When you try to edit a stream with a open CREQ you can see the forms -- but when you submit you get an error:

Code: Select all

ERROR: DB ERROR - ACCESS DENIED - change request for this entry pending
Is it not better to view the CREQ instead of a form as for other CREQ's



No link to file for ADD CREQ's of streams.
ex:
http://anidb.info/perl-bin/animedb.pl?s ... .id=304187
It's impossible for me to see with file i have requested changes for...

Locked