New random features from backup restore

already fixed bugs

Moderator: AniDB

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

New random features from backup restore

Post by Rar » Mon Nov 28, 2005 5:21 pm

There are various issues with the restored anidb
  • Information added on the last day of operation may be gone. Just have to live with this, add it again.
  • Images added since June will be gone, so expect lots of missing pictures. Can hopefully be recovered from the old server at some point. Quite a few uploaded from people's AOM folders etc.
  • Gzip is not currently being enforced
  • mod_throttle is not currently working We have throttle
  • No Chii yet. <EXP[BUSY]> chii will be back tomorrow (promised 2005-11-28T5:22 GMT) She's back, and hawter than ever.
  • AOM will behave badly. If you believe in safety, don't use AOM till petri puts out a new version. New version out, use that!
  • .hack//sign is now collating under '.' it was under 'h' in the past
  • <SLSneak> FYI> The links to the examples on the mylist export page are broken Should all be fixed now, need to export again if one was requested before the fix.
  • WebAOM broken due to lack of gzip Fixed, get the (silent) new version.
  • Some rel graphs seem to have issues.
  • Possible problem with account email notifications, beyond the usual? Seem to be fixored.
  • Exp is still serving iso-8859-1 etc, old bugs all still exist
Feel free to respond with extra stuff (and mods edit this post to add confirmed stuff/strike resolved stuff).
Last edited by Rar on Fri Dec 02, 2005 4:43 am, edited 3 times in total.

User avatar
ricce
Posts: 199
Joined: Wed Apr 06, 2005 8:42 pm
Location: Sweden / Västrås
Contact:

Post by ricce » Mon Nov 28, 2005 7:21 pm

WebAOM (UDP API) fails att two points:
  • Can't modify mylist - nothing is accually happaning
  • Renaming broken (WebAOM assume connection is gzip:ed)

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Mon Nov 28, 2005 8:31 pm

Latest AOM should fix the TCP API downgrade.

XavierBlak

Post by XavierBlak » Mon Nov 28, 2005 8:33 pm

So far on the two series I tried to add as watched this has happened.

I expand the whole series and check each episode off and then select "watched" and "on hdd". It will add them to my list but not as watched. If I go back and on each episode select "mark file as watched" it will then mark it as watched but will oddly open another browser window.

That's all I've noticed so far. Great to have anidb up and running again. :)

epoximator
AniDB Staff
Posts: 379
Joined: Sun Nov 07, 2004 11:05 am

Post by epoximator » Mon Nov 28, 2005 8:51 pm

i have already fixed webaom. (did it silently, hoped no one would notice the bug, hehe)

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

Post by Rar » Mon Nov 28, 2005 9:01 pm

I take it you're being good on the gzip front and responding to the Content-Encoding header now epoxy, rather than guessing? I'll whip you if that's not the case.

Rar

epoximator
AniDB Staff
Posts: 379
Joined: Sun Nov 07, 2004 11:05 am

Post by epoximator » Mon Nov 28, 2005 9:33 pm

hehe, yeah. it did actually try to check the header, but it failed with a null pointer exception...

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Tue Nov 29, 2005 2:30 am

enforced gzip compression will be back at some point :P

BYe!
EXP

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Tue Nov 29, 2005 4:26 am

* chii is back
* mylist export examples, queueing and downloading should work now
* uploaded an image pack with more recent anime images by baka-san

User avatar
DonGato
Posts: 1296
Joined: Sun Nov 17, 2002 9:08 pm
Location: The Pampas, The land of the Gaucho!
Contact:

Post by DonGato » Tue Nov 29, 2005 7:16 am

29.11.2005 03:48 [EXPORT] Mylist Export is ready for download mail is empty. Will try again.

MilesMi
Posts: 13
Joined: Fri Jan 07, 2005 11:18 pm

Post by MilesMi » Tue Nov 29, 2005 11:47 am

DonGato wrote:29.11.2005 03:48 [EXPORT] Mylist Export is ready for download mail is empty. Will try again.
I came here just to inform this. Mylist export is buggy. Both the message and the mylist export page contain a 0-character link pointing to http://anidb.info/export/ , and nothing there.

User avatar
DonGato
Posts: 1296
Joined: Sun Nov 17, 2002 9:08 pm
Location: The Pampas, The land of the Gaucho!
Contact:

Post by DonGato » Tue Nov 29, 2005 12:00 pm

Did it again this morning and it worked. Now don't know if it's random working or not. :/

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

Post by Rar » Tue Nov 29, 2005 3:19 pm

My interpretation of exp's fix is that you any exports requested before he fixored it will be borked, all exports from now on should be fine.

Rar

BelGarion
Posts: 24
Joined: Thu Nov 24, 2005 4:40 am

Post by BelGarion » Tue Nov 29, 2005 11:48 pm

Also registration email isn't working one bit, got a bunch of complaints, mine included, on this issue @

http://www.anidb.net/forum/viewtopic.php?p=23159#23159

I hope it gets fixed soon, I wanted to look up a few hentai animes but can't until I can reauth my account. :P Thanx!

BelGarion

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Fri Dec 02, 2005 5:14 am

I don't know why the graphs are sometimes broken, but my current guess is that it is caused by anime titles which are too long.
see this example:

http://anidb.info/pics/graph/g-17.gif
generated by
http://anidb.info/pics/graph/g-17.dot

anyone any ideas how to fix this in graphviz?
otherwise I'd have to truncate long names.

BYe!
EXP

Locked