[AOM 0.5.1-4] stuck with 100% CPU usage [FIXED]

Bug reports for an official AniDB Client go here

Moderators: AniDB, AniDB API

User avatar
exp
Site Admin
Posts: 2438
Joined: Tue Oct 01, 2002 9:42 pm
Location: Nowhere

Post by exp » Fri Nov 25, 2005 4:11 am

Techno Mage wrote:Realy im after a program to auto name my files, ready for Net TV, but i gess ile have to make it myself.
that sounds very much like something WebAoM could do for you.

BYe!
EXP

jcd4878

Post by jcd4878 » Tue Nov 29, 2005 1:51 pm

After some more playing around I think I found the problem. Apparently Delphi apps have issues with Nvidia's Desktop Manager. I turned off all support for the NVidia desktop manager, and now AOM no longer hangs up or crashes randomly. I used it several times now to add large groups of files, and AOM seems to be rock solid stable now.

If anyone else who is having crash/hang problems uses NVidia desktop manager, turn it off. The feature is also know as NVidia nView.

I guess the crazy stuff nView does to put nVidia menu items and caption bar buttons on every Windows app causes Delphi apps to crash and hang. I can live without the nView features for now.

-Jerry

TechnoMage
Posts: 26
Joined: Fri Dec 16, 2005 11:35 pm

Post by TechnoMage » Sat Jan 07, 2006 2:50 pm

Nope still freezes, even on a 2003 machine not running nvidia it freezes, the freezing has nothing to do with nvidia, its a delphi threading problem. XP and above are better a handling threads, delphi expects them to move at the same pace, and freezes.

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sun Jan 08, 2006 11:21 am

TechnoMage wrote:Nope still freezes, even on a 2003 machine not running nvidia it freezes, the freezing has nothing to do with nvidia, its a delphi threading problem. XP and above are better a handling threads, delphi expects them to move at the same pace, and freezes.
This is something with YOUR configuration, you're the only one reporting this error. I run aom on HT cpu WinXP 24/7 and have no problem.
If it happens with more delphi applications it's just more proof it's not aom itself but something on your end.

User avatar
Rar
AniDB Staff
Posts: 1471
Joined: Fri Mar 12, 2004 2:41 pm
Location: UK
Contact:

Post by Rar » Sun Jan 08, 2006 1:22 pm

Anyway, as petri said, you can just use WebAOM for hashing/renaming instead. Unless Java freezes your machine as well?

Rar

Crazy

Post by Crazy » Tue Jan 10, 2006 8:16 pm

I've found the reason why it always went to 100% cpu usage in my case,
it is like someone said before nView Desktop Management.
I was using this for my dualview.

By turning it off it seems to have stopped all crashes.
Btw, using latest nvidia drivers now, but also had the crashes with previous driver versions.

Anyhow, I'm glad I found the reason, as soon as I turned it off, i havn't had a single crash.

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Tue Jan 10, 2006 10:18 pm

nView seems to cause compability issues with A LOT of software.

TechnoMage
Posts: 26
Joined: Fri Dec 16, 2005 11:35 pm

Post by TechnoMage » Thu Jan 12, 2006 2:16 am

Ive tryed AOM on the following configs
P4 3GHz HT 1G RAM Windows 2003
P4 3GHz HT(off) 1G RAM Windows 2003
P4 3GHz HT 1G RAM Windows XP
P4 3GHz HT(off) 1G RAM Windows XP
P4 1.6GHz 512MB RAM Windows XP
P4 1.6GHz 512MB RAM Windows 2003
Microsoft Virtual PC 2004 512MB RAM Windows XP
Microsoft Virtual PC 2004 512MB RAM Windows 2003

All except the virtual, with and with out a nvidia video card, and RAIDON video card

All either crash or freeze AOM

Ive neaver had a delphi 7 or less program NOT freeze or crash since XP SP2, its a well known delphi bug.

Anyway since it has what i need, ive started remaking it myself.

PS its only Delphi that has a problem, and who wants to just rename files!

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Thu Jan 12, 2006 9:31 am

TechnoMage wrote:Ive tryed AOM on the following configs
P4 3GHz HT 1G RAM Windows 2003
P4 3GHz HT(off) 1G RAM Windows 2003
P4 3GHz HT 1G RAM Windows XP
P4 3GHz HT(off) 1G RAM Windows XP
P4 1.6GHz 512MB RAM Windows XP
P4 1.6GHz 512MB RAM Windows 2003
Microsoft Virtual PC 2004 512MB RAM Windows XP
Microsoft Virtual PC 2004 512MB RAM Windows 2003

All except the virtual, with and with out a nvidia video card, and RAIDON video card

All either crash or freeze AOM

Ive neaver had a delphi 7 or less program NOT freeze or crash since XP SP2, its a well known delphi bug.

Anyway since it has what i need, ive started remaking it myself.

PS its only Delphi that has a problem, and who wants to just rename files!
You still seem to fail to understand that noone else has this problem right? The company where I work has delphi 5 and delphi 7 software running on TENS OF THOUSANDS of windows XP machines that don't have this problem.

I had never even heard of the problem before you posted about it. A quick check at the borland quality central shows no bug report of this kind, the only thing that might happen that I see there is a race condition when a thread is freed (which only happens if you're hashing files).


Instead, I suggest you start looking at your computer configuration. Something you do (config, change services, etc) or install (driver, software and/or hardware) with Windows is causing this, not delphi.

swtrse
Posts: 17
Joined: Thu Jan 12, 2006 8:24 pm

Post by swtrse » Fri Jan 13, 2006 5:32 am

I do not think that this problem is only hit a few users.
I also have these kind of problem ususally ofter an hour of running AOM.

My to notes about that.
My System: AMD64 3GHz WinXPx64 2GB Ram

I realized that this problem 100% CPU usage occur wenn validating known files. Well it was always possible to kill AOM and start again. I think the problem shows up if some unknown files are in the known files list.
SInce I deletet all files that are unknown the 100% CPU usage problem did'n occur anymore.

Maybe that helps tracking the bug down.

PS: Moste of the unknowfiles where pictures because I just addet a folder with all subfolders so there where 200-300 and more unkown files in the list.

TechnoMage
Posts: 26
Joined: Fri Dec 16, 2005 11:35 pm

Post by TechnoMage » Tue Feb 07, 2006 3:55 am

I do have unknown files, ile try removing or changing them

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Tue Feb 07, 2006 7:07 am

If you've missed it, there is a known issue where corrupt avi files will cause the hashing thread to use 100% cpu. However, this will not make aom itself stop responding.

Lightdestroyer

Post by Lightdestroyer » Tue Feb 28, 2006 1:40 pm

i do have the same problem --> random freezes ..
mostly in my list or know list ...
100% cpu usage that jumps to explorer.exe...

but i do run nvidea desktop,
when i turn that off, it seems that the problem is solved (at least it doesn't happen that frequently ..)

happy that problem is solved for me :]
cause AOM is really good!!!

Locked