[AOM 0.5.1-4] stuck with 100% CPU usage [FIXED]

Bug reports for an official AniDB Client go here

Moderators: AniDB, AniDB API

Skal
Posts: 11
Joined: Thu Jan 22, 2004 2:48 pm

[AOM 0.5.1-4] stuck with 100% CPU usage [FIXED]

Post by Skal » Sat Oct 16, 2004 12:42 pm

Not sure what's going on, but my client is now stuck every time I start it at the same part, namely at "converting and saving new anime title data".
The CPU usage remains at 100%, and I have to kill the client using task manager.

I tried to erase all files in my kowai folder, except for the local ones.
When the client restart, it downloads ok all the information, but is stuck again at the same part.

It was working fine until two days ago, and I didn't change anything in my configuration, so I'm clueless about how to fix it.

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sat Oct 16, 2004 12:50 pm

Yeah, just got this myself, I'll look into it.

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sat Oct 16, 2004 12:56 pm

I've fixed the title which was causing it, I think the bug is fixed in AOM 0.6 (which will be released some day!).

So just restart AOM and it'll update properly.

Skywalka
Posts: 889
Joined: Tue Sep 16, 2003 7:57 pm

Post by Skywalka » Sat Oct 16, 2004 6:55 pm

PetriW wrote:I've fixed the title which was causing it, I think the bug is fixed in AOM 0.6 (which will be released some day!).
You sound more and more like microsoft announcing Windows 64...

*snicker*

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sun Oct 17, 2004 9:46 am

Just you wait! (err... that was kinda...)

User avatar
fahrenheit
AniDB Staff
Posts: 438
Joined: Thu Apr 08, 2004 1:43 am
Location: Portugal

Post by fahrenheit » Sun Oct 17, 2004 11:34 am

Or Valve announcing TFC2 or Half-Life 2 :P

it will be released! Eventualy :P

Der Idiot
AniDB Staff
Posts: 1227
Joined: Fri Mar 21, 2003 10:19 am

Post by Der Idiot » Sun Oct 17, 2004 12:04 pm

3 words: duke nukem forever
;)

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sun Oct 17, 2004 2:20 pm

fahrenheit wrote:Or Valve announcing TFC2 or Half-Life 2 :P

it will be released! Eventualy :P
HL2 has gone gold.

kidan
Posts: 319
Joined: Thu Feb 13, 2003 9:13 pm
Location: .DE

Post by kidan » Mon Oct 18, 2004 1:20 am

Didn't HL2 get open-sourced by force before? Just like WinNT and DOS ;)

iBooks

Post by iBooks » Sun Jan 23, 2005 9:48 pm

This same behaviour is happening again (100% CPU, crashing), except with anime vote data.

Please fix this, thank you! :)

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Sun Jan 23, 2005 10:26 pm

Was with an anime title, it's been handled again.

User avatar
shaman
Posts: 23
Joined: Tue Feb 15, 2005 9:01 pm
Location: Vilnius, Lithuania
Contact:

Post by shaman » Tue Feb 15, 2005 9:04 pm

Ghm same here. It usually happens while browsing Know files section. I kill the proccess but usually it brings the whole system down (I'm using Windows 2000 on AMD with 1G RAM).
The thing that i have to reboot after using AOM really sux ;)

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Tue Feb 15, 2005 11:09 pm

shaman wrote:Ghm same here. It usually happens while browsing Know files section. I kill the proccess but usually it brings the whole system down (I'm using Windows 2000 on AMD with 1G RAM).
The thing that i have to reboot after using AOM really sux ;)
Sounds like one of your harddrive disks is failing.

AoM itself shouldn't have anything that can actually crash your system, sure it might use cpu but nothing in the program itself should cause trouble if you ctrl+alt+del it, rather it's something like reading from disk or tother hardware/software issues that causes this.

User avatar
shaman
Posts: 23
Joined: Tue Feb 15, 2005 9:01 pm
Location: Vilnius, Lithuania
Contact:

Post by shaman » Wed Feb 16, 2005 4:13 pm

Ghm.... Well as I have noticed the system crashes cause after AOM crashes and it is killed other proccesses reach 100% one by one (e.g. notepad, iexplore, anypass were running while i was using AOM, when i killed AOM i switched to notepad and seconds later it also reached 100% CPU, the iexplore and finally explorer.exe ;) ).
I don't know whether it's my hardware or AOM, but such weird stuff happens only when AOM is started and it yet happend only while browsing local files.

PetriW
AniDB Staff
Posts: 1522
Joined: Sat May 24, 2003 2:34 pm

Post by PetriW » Wed Feb 16, 2005 6:34 pm

Well, I seriosly doubt instability of this kind is AoMs fault.

Locked