Page 1 of 1

Can't access the AniDB API

Posted: Fri Oct 05, 2007 9:24 am
by antennen
I could access the API until two weeks ago, using my own client (Jeeves). However it just stopped working. The first thing my client do is to send a PING to verify connection. Now it doesn't get past that, no response. I've tried both and

Today I tried to access it using

Code: Select all

nc 9000
300 PONG
AUTH user=antennen&pass=xxxxxx&protover=3&client=jeeves&clientver=1
PING worked just fine but as soon as i tried AUTH it complained.

To check if it was my client or something i tried WebAOM too, but with the same outcome. No response. What am I doing wrong?

Hmm. I just realized that I'm probably banned because it worked on another box. But why am I banned?


Posted: Fri Oct 05, 2007 10:10 am
by epoximator
1. read the netcat manual (-u)
2. one ip is banned for leeching, which is probably you. it has been banned for quite some time. remember, if send a packet when banned, you'll reset the ban time.

Posted: Fri Oct 05, 2007 10:59 am
by antennen
Seems that the database had accidently deleted the majority of files (1700) and now the client was trying to readd them. Well at least I know the cause. Time to rebuild the database. This will take hours :/

Note to self: Never forget to backup the database.